Customers may experience intermittent 502 errors when viewing and retrieving assets on app.eu-central-1.saucelabs.com. The cause is an incident affecting a third party vendor (AWS). Updates are here: https://status.aws.amazon.com/
2019-October-4 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

Dates:

October 4th, 2019 08:30am - 10:30am PDT

What happened:

Some customers experienced issues while starting automated Appium tests for Android and iOS real devices in our European data center.

Why it happened:

A high load of misconfigured test requests reached our systems which were causing those to not properly free resources in our services up to a point where new valid requests couldn't be handled by some instances of our services

How we fixed it:

We manually assigned additional resources to the affected services and deployed a fix to reject misconfigured jobs early.

What we are doing to prevent it from happening again:

We refined our test request validation and will add further measure to block misconfigured requests early.

Posted Nov 25, 2019 - 17:35 CET

Resolved
Automated RDC tests are running successfully. All services are fully operational.
Posted Oct 04, 2019 - 19:31 CEST
Monitoring
We have taken remedial action and tests should start.
Posted Oct 04, 2019 - 18:59 CEST
Identified
Devices cannot be allocated on most automated mobile tests run on our European Data Center, for both iOS and Android. We are taking remedial action.
Posted Oct 04, 2019 - 18:28 CEST
This incident affected: Automated RDC Testing (Automated RDC Testing).