Customers may experience intermittent 502 errors when viewing and retrieving assets on app.eu-central-1.saucelabs.com. The cause is an incident affecting a third party vendor (AWS). Updates are here: https://status.aws.amazon.com/
2019-February-27 Service Incident
Incident Report for Sauce Labs European Data Center
Resolved
Tunnels are working normally again and the issue has been resolved. All services are fully operational.
Posted Feb 28, 2019 - 02:15 CET
Investigating
Sauce Connect tunnels are not able to be created. We are investigating.
Posted Feb 28, 2019 - 01:38 CET
This incident affected: Sauce Connect (Sauce Connect VM).