Customers may experience intermittent 502 errors when viewing and retrieving assets on app.eu-central-1.saucelabs.com. The cause is an incident affecting a third party vendor (AWS). Updates are here: https://status.aws.amazon.com/
2019-July-08 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

Dates:

Jul 8, 20:15 - 20:43 CEST

What happened:

Android Emulator tests in the European data center were unable to start

Why it happened:

Due to a slight difference in configuration across regions, a change deployed globally to our Android Emulator Clouds caused a conflict in our European region.

How we fixed it:

We moved quickly to revert to the last known good configuration.

What we are doing to prevent it from happening again:

We’re adding additional services checks to our configuration deploy system to block changes like this in the future. We’re continuing to update all dependent services to latest versions to reduce the range of previous configurations that need to be maintained.

Posted Jul 29, 2019 - 23:11 CEST

Resolved
Android Emulator tests in the European data center are starting normally.
Posted Jul 08, 2019 - 20:43 CEST
Investigating
Android Emulator tests in the European data center cannot start.
Posted Jul 08, 2019 - 20:15 CEST
This incident affected: Automated VM Testing (Automated Android Emulator Testing).