Customers may experience intermittent 502 errors when viewing and retrieving assets on app.eu-central-1.saucelabs.com. The cause is an incident affecting a third party vendor (AWS). Updates are here: https://status.aws.amazon.com/
2020-February-25 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

Dates:

Tuesday February 25 15:14 - 16:04 CET

What happened:

Automated and live tests would not start on any of our clouds. In the recovery phase, wait times were high for Windows 10 and Windows 2008.

Why it happened:

The application of new security rules affected communication between critical services.

How we fixed it:

We investigated and updated the security rules.

What we are doing to prevent it from happening again:

We are implementing a plan to identify all security rules and take steps to improve our release process.

Posted Mar 06, 2020 - 18:00 CET

Resolved
All wait times are back to normal and tests are starting normally. All services are fully operational.
Posted Feb 25, 2020 - 18:52 CET
Update
Wait times are returning to normal and we are monitoring the recovery.
Posted Feb 25, 2020 - 18:17 CET
Monitoring
Wait times for Windows tests are improving. We continue to monitor closely.
Posted Feb 25, 2020 - 16:41 CET
Identified
We are taking remedial action. Mac, iOS and Android tests are now starting correctly. Wait times are elevated for Windows tests.
Posted Feb 25, 2020 - 16:19 CET
Investigating
Automated and live tests are not starting. We are investigating.
Posted Feb 25, 2020 - 15:51 CET
This incident affected: Manual Testing (Manual VM Testing) and Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing).