A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2020-September-9 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

Dates:

Wednesday, September 9 17:30 - 21:40 CEST

What happened?

Some customers received erroneous messages stating they were running at their maximum concurrency.

Why did it happen?

During a routine deploy, a serialization library was updated. This update contained a hidden dependency with a non-compatible, breaking change which made the read and write values of this service to not work.

How was it resolved?

The deployment was rolled back.

What are we doing to prevent it from happening again?

We are improving our endpoint monitoring to detect stale values and other anomalies and improving dependency monitoring and alerts when a cross-dependency gets updated. We are also enhancing the deploy process of this service to ensure changes are properly validated before getting deployed.

Posted Sep 25, 2020 - 11:45 CEST

Resolved
We have taken remedial action and the rest/v1.2/concurrency endpoint should return accurate data. Your concurrency meter in the user interface should also be working again.
Posted Sep 09, 2020 - 21:49 CEST
Investigating
The /rest/v1.2/users/USERNAME/concurrency endpoint is not showing an accurate concurrency value. We are investigating and taking remedial action. Your concurrency meter in the user interface may not show the correct value.
Posted Sep 09, 2020 - 21:39 CEST
This incident affected: REST API (REST API VMs) and Web Interface (Sauce UI).