2021-January-22 Resolved Service Incident
Postmortem

Dates:

Friday, January 22 12:00 - 13:30 CET

What happened:

Logging into the legacy Real Device Cloud UI from the Sauce Labs dashboard was failing. Customers may have also seen app installation failures and failures launching the browser in live RDC tests from the Sauce Labs dashboard.

Why it happened:

A new API Gateway version was deployed which introduced the need for the new configuration, for which the RDC UI clients were not prepared.

How we fixed it:

We rolled back API Gateway to the previous version.

What we are doing to prevent it from happening again:

We’re adding detailed logging for all requests sent to our API Gateway from clients that might stop working due to the API Gateway upgrade. Additionally monitoring tests for integration with Legacy RDC and Live Testing will be improved to catch any issues as soon as it’s possible.

Posted Jan 29, 2021 - 00:22 CET

Resolved
Between 12:00 and 13:30 CET today, logging into the Legacy RDC UI from the Sauce Labs Dashboard was failing. Customers may have also seen app installation failures and failures launching the browser in Live Real Device tests from the Sauce Labs Dashboard. A fix was deployed which solved both issues
Posted Jan 22, 2021 - 13:30 CET