A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-September-12 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

IM-218, Customer Facing Post Mortem September 12th, 2019

Dates:

September 12th, 2019 5:52 PM - September 12th, 2019 7:16 PM CEST.

What happened:

Appium tests failed to start if our service could not allocate a device for the test within 3 minutes. This was true on both the European and US data centers.

Why it happened:

We changed the behavior of how pending (scheduled) Appium sessions work. Pending sessions were being cleaned up before the Appium client got a response from the server signaling successful session creation.

How we fixed it:

We realized this was an issue introduced in the last release, so we rolled back to the last stable release.

What we are doing to prevent it from happening again:

We are adding test cases in our staging environment in order to prevent us from deploying broken releases. We are setting up alerts to notify us when the Appium session creation success rate decreases significantly.

Posted Oct 07, 2019 - 20:04 CEST

Resolved
All services are now fully operational.
Posted Sep 12, 2019 - 19:16 CEST
Update
We are continuing to take remedial action for this problem which only affects our real device cloud.
Posted Sep 12, 2019 - 18:20 CEST
Identified
We are experiencing a high failure rate for Appium tests. We are taking remedial action that will stop all running Appium tests for a short period of time.
Posted Sep 12, 2019 - 17:52 CEST
This incident affected: Automated RDC Testing (Automated RDC Testing).