A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-October-4 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

Dates:

October 4th, 2019 04:30am - 7:30am PDT

What happened:

Some customers experienced issues while starting automated Appium tests for Android and iOS real devices in our European data center.

Why it happened:

A high load of misconfigured test requests reached our systems which were causing those to not properly free resources in our services up to a point where new valid requests couldn't be handled by some instances of our services

How we fixed it:

We manually assigned additional resources to the affected services and deployed a fix to reject misconfigured jobs early.

What we are doing to prevent it from happening again:

We refined our test request validation and will add further measure to block misconfigured requests early.

Posted Nov 25, 2019 - 17:35 CET

Resolved
We’ve taken remedial action and automated mobile tests are running again. All services are fully operational.
Posted Oct 04, 2019 - 16:50 CEST
Investigating
Devices cannot be allocated on most automated mobile tests run on our European Data Center, for both iOS and Android. We are investigating.
Posted Oct 04, 2019 - 16:18 CEST
This incident affected: Automated RDC Testing (Automated RDC Testing).