2020-September-17 Service Incident
Postmortem

Dates:

Thursday, September 17 06:20 - 09:20 CEST

What happened?

Live tests on desktop browsers, mobile emulators and mobile simulators failed to start.

Why did it happen?

We deployed an update to our VM configuration and management software that inadvertently prevented our in-browser live testing client from starting new sessions.

How was it resolved?

Our monitoring systems detected the issue and the deployment was rolled back.

What are we doing to prevent it from happening again?

We are simplifying the complexity of our VM configuration and management software and implementing additional unit tests for the affected components, as well as further improving monitoring and alerting.

Posted Sep 25, 2020 - 11:47 CEST

Resolved
Live Testing functionality has been restored. All services are fully operational.
Posted Sep 17, 2020 - 09:23 CEST
Investigating
Live Testing sessions fail to open correctly for Emulators, Simulators and Desktop. Live Testing on Real Devices is fully operational. Our engineers are investigating.
Posted Sep 17, 2020 - 08:46 CEST