Customers may experience intermittent 502 errors when viewing and retrieving assets on app.eu-central-1.saucelabs.com. The cause is an incident affecting a third party vendor (AWS). Updates are here: https://status.aws.amazon.com/
2019-February-27 Service Incident
Incident Report for Sauce Labs European Data Center
Resolved
The Automated Test tab has returned to normal. All services are fully operational.
Posted Feb 28, 2019 - 05:31 CET
Investigating
The Automated Tests tab is returning a 500 error. Other services are working and tests should continue to run as normal.
Posted Feb 28, 2019 - 05:00 CET
This incident affected: Web Interface (Sauce UI).