A SSL certificate in the chain of the certificate used for TLS 1.2 on https://app.testobject.com has expired.
Any client (web browser, REST API client) using TLS 1.2 and making requests to https://app.testobject.com may see “certificate has expired” errors. Any client using TLS 1.3 is unaffected. We are working to rectify this issue.
2019-May-17 Service Incident
Incident Report for Sauce Labs European Data Center
Postmortem

Dates:

May 17, 16:38 - 17:39 CEST

What happened:

Our EU Tunnel Cloud wasn’t able to service any new Sauce Connect Tunnel requests.

Why it happened:

An automated operating system update upgraded a key service on our Tunnel Cloud leaving it unable to complete any new Sauce Connect Tunnel requests.

How we fixed it:

We corrected this by restarting the service and throttled new requests at 50% until the service was able to stabilize.

What we are doing to prevent it from happening again:

We’ve disabled the automated operating system updates. Additionally, we’re updating the related services so they’re more tolerant of restarts. Finally, we’re improving our monitoring so that we can react more quickly to this class of issue.

Posted May 23, 2019 - 18:11 CEST

Resolved
Tunnels should now start in the European Datacenter.
Posted May 17, 2019 - 17:43 CEST
Investigating
European Datacenter tunnels cannot start. We are working to resolve the issue.
Posted May 17, 2019 - 17:24 CEST
This incident affected: Sauce Connect (Sauce Connect VM).