Customers may experience intermittent 502 errors when viewing and retrieving assets on app.eu-central-1.saucelabs.com. The cause is an incident affecting a third party vendor (AWS). Updates are here: https://status.aws.amazon.com/
Resolved: 2019-March-15 Service Incident
Incident Report for Sauce Labs European Data Center
Resolved
Today between 12:43 AM - 2:20 AM PDT, many tests were not able to start. Tests that did start had high wait times.
Posted Mar 15, 2019 - 21:13 CET
This incident affected: Automated VM Testing (Automated PC Testing, Automated Mac Testing, Automated iOS Simulator Testing, Automated Android Emulator Testing).